aktuelle 180.XX nVidia Linux Display Driver

Moderator: ZRUF

aktuelle 180.XX nVidia Linux Display Driver

Beitragvon Goldfield » Fr 14. Nov 2008, 15:23

nVidia Linux Display Drivers 180.06 (BETA)


Download:

nVidia Display Drivers 180.06 (BETA) for Linux x86
http://www.nvidia.de/object/linux_display_ia32_180.06_de.html

nVidia Display Drivers 180.06 (BETA) for Linux x64 (AMD64/EM64T)
http://www.nvidia.de/object/linux_display_amd64_180.06_de.html


Sonstiges:

If you have a performance problem, PLEASE read this first:
http://www.nvnews.net/vbulletin/showthread.php?t=118088

If you have a stability problem, PLEASE read this first:
http://www.nvnews.net/vbulletin/showthread.php?t=58498


Edit:

Changelog:
http://www.nvnews.net/vbulletin/showthread.php?t=123072

Edit: habe das Thema mal geändert, passt besser, da ich nicht für jeden Treiber einen neuen Thread aufmachen will.
Goldfield
 

aktuelle 180.XX nVidia Linux Display Driver

Beitragvon lazy » Fr 14. Nov 2008, 17:03

schon erfahrungen? das changelog klingt eigentlich interessant finde ich
lazy
 

aktuelle 180.XX nVidia Linux Display Driver

Beitragvon Goldfield » Fr 14. Nov 2008, 20:19

Ja, läuft gut. Spürbare Verbesserung im Firefox, wie ich finde, jedenfalls unter KDE. glxgears ist ungefähr wie vorher, aber was will man bei Werten um die 2000 :) auch erwarten. Ansonsten bin gerade auf 64bit umgestiegen und schlage mich im Moment mit iommu-Problemen rum.
Goldfield
 


aktuelle 180.XX nVidia Linux Display Driver

Beitragvon Goldfield » Fr 14. Nov 2008, 22:49

Your BIOS doesn’t leave a aperture memory hole.................

Jepp, genau diese Meldung. \"free\" zeigt mir an, das 64MB RAM abgezwackt werden, dmesg sagt:

Checking aperture...
No AGP bridge found
Node 0: aperture @ fff4000000 size 32 MB
Aperture beyond 4GB. Ignoring.
Your BIOS doesn\'t leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM
Mapping aperture over 65536 KB of RAM @ 20000000
PM: Registered nosave memory: 0000000020000000 - 0000000024000000

PCI-DMA: Disabling AGP.
PCI-DMA: aperture base @ 20000000 size 65536 KB
PCI-DMA: using GART IOMMU.
PCI-DMA: Reserving 64MB of IOMMU area in the AGP aperture


So wie ich das verstanden habe, möchte der Kernel Speicher für den nicht vorhandenen AGP \"reservieren\". Die Fehlermeldung habe ich mit \"iommu=noagp,noaperture\" (in der xorg.conf muss dafür -Option \"NvAgp\" \"0\"- gesetzt sein) wegbekommen. Keine Probleme bis jetzt, außerdem werden nur noch 32MB vom RAM geklaut, nicht mehr 64MB.

Folgende Seite war hilfreich:
http://ww2.cs.fsu.edu/~rosentha/linux/2.6.26.5/docs/x86_64/boot-options.txt
Goldfield
 

aktuelle 180.XX nVidia Linux Display Driver

Beitragvon lazy » Sa 15. Nov 2008, 01:45

jau.. klappt dann aber trotzdem (leider) nicht mit dem (neuen) ath9k treiber.. der scheint da speichermässig sehr komisch zu fungieren, ich hoffe, das eine kommende version das ein wenig fixt.. sonst dreht mein dad durch.. ;)

ums genauer auszudrücken, das problem ist, der ath9k treiber will immer genau diesen bereich ausfüllen... und deshalb freezed das sys dann immer.. es hilft zwar, den bereich zu erhöhen.. also von 64 auf 256 z.b. aber selbst dann freezed der ath9k treiber das sys nach hmm paar minuten
lazy
 

aktuelle 180.XX nVidia Linux Display Driver

Beitragvon Goldfield » Sa 15. Nov 2008, 01:55

was steht den in der dmesg bzw kernel.log?
Goldfield
 

aktuelle 180.XX nVidia Linux Display Driver

Beitragvon lazy » Sa 15. Nov 2008, 02:00

puh.. das der ath9k den speicherbereich belegen will aber kein platz hat, das rennt dann x fach von oben nach unten durch und das sys freezed -g- also könnte sicherlich u.U. auch am ath9k treiber liegen.. so wie ich das aus all den bug threads herauslesen kann.. ist ein zusammenspiel von beiden faktoren, denn ich weiß von meinem eigenen system her (ohne atheros gott sei dank), das die meldung zwar nervt bzw das 64mb weg sind (bzw 32mb), aber es zu keinen freezes führt.. es liegt wirklich (so denke ich nach paar tagen mit vielen hm versuchen) daran, das der ath9k treiber etwas seltsam den speicher anspricht..bzw dies will, und dadurch nicht kann.. das mit iommu kommt ja nich überall vor.. hier bei mir explizit asrock-bios bedingt.. bei dir (sehe leider keine sig.. liegt an mir) denke ich, wirds ähnlich sein, leider.

im prinzip handelt es sich ja um einen bios bug den es schon sehr sehr lange gibt.. so wie ich das aus all den infos herauslesen konnte.
lazy
 

aktuelle 180.XX nVidia Linux Display Driver

Beitragvon Goldfield » Sa 15. Nov 2008, 02:10

klar, ASRock ;) , das AliveNF7G-HDReady. Könntest das mal versuchen: http://linuxwireless.org/en/users/Download#Directlydownloadingthetarball
Bist du die Optionen auf der verlinkten Seite mal durchgegangen?
swiotlb=65536 (128MB) oder swiotlb=131072 (256MB) soll schon mal geholfen haben

Edit:
Habe mal im sidux-Forum gesucht, steht so gut wie nichts über den ath9k:
http://sidux.com/index.php?module=pnWikka&tag=NetworkAtheros
http://madwifi-project.org/wiki/Compatibility

Was mir noch einfällt, hast du die Karte mal umgesteckt?

Ansonsten, RAM begrenzen (mem=3G) bis ein Patch für den Kernel verfügbar ist......
Goldfield
 

aktuelle 180.XX nVidia Linux Display Driver

Beitragvon lazy » Sa 15. Nov 2008, 08:46

guten morgen goldfield,

hab das alles ausprobiert.. am ende passiert immer das gleiche leider mit dem ath9k -g- ich warte und gedulde mich auf einen patch oder fix.. und hab den ath9k auf der blacklist erstmal
lazy
 

Nächste

Zurück zu Linux

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron